Skip to main content
(*.233.123.176) 조회 수 22920 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

운영체제는 당연히 윈도우 계열이구요~

apm_setup7 설치후...

cubrid 독립적으로 설치후...

php.ini 를 아무리 건드려 봐도... 익스텐션으로 로드 되지 않아서...


cubrid 홈피가서 알아낸 결과... 해결됨~

----------------------------

방금 apm_setup7 이란걸 설치하고 cubrid 연동을 계속 하다가... 특별히 잘못한 것이 없는데...
cubrid만 php모듈로 로드가 안되서... 결국 원인을 여기서 찾았네요...

%CUBRID%\bin\cascci.dll 을 apache 설치 디렉토리 아래 bin 으로 복사후 재구동하면 됩니다.

OS는 XP 이지만... 이건 2003에 APM 돌릴때랑도 상황은 비슷할것 같습니다.
궁금한 것은 왜... APACHE에 cascci.dll 이란걸 넣어야 하냐는 겁니다.
일반적으로 apache, php, mysql을 사용하게 되는데요~

mysql과 비교해서 좀 그렇지만... 그래도... mysql 같은 경우 php.ini 파일에 주석만 풀어 주면 되는데요~
만약 이 과정이 반드시 필요한 조치라면... 설치가이드쪽 게시판에 언급이 되어야 할 것 같습니다.

그리고 php extention dll 파일의 종류가 여러개 인데... 어떤 버전에 어떤 파일인지도 마니 혼란 스럽네요~
php_cubrid.dll  <-- apm_setup7 에 함께 배포된 파일(cubrid에서 공식적으로 배포한 php 5.2.x버전용 파일임)
php_cubrid_php5.3.dll <-- apm_setup7 에 함께 배포된 파일(cubrid에서 공식적으로 지원하지 않는 php5.3.x 버전용 파일임... 아무래도 apm_setup7에서 자체적으로 만든게 아닌가 생각됩니다~ ^^)
cubrid2008_php5.3.dll  <-- 이것도 비공식적으로 누군가(?) 만든 php5.3.x 버전 지원용 파일인듯...

----------------------------


실제로 검색해서 해결하고 댓글을 남긴 주소임~ ㅋㅋ (집요하군~ -_-)

http://cubrid.com/zbxe/64364




위의 지저분한 글들을 요약하자면...

cubrid는 2010년 4월 1일 현재까지 공식적으로 php 5.3.x 버전을 지원하지 않으면...

php 5.3.x 버전에서 그나마 작동되게 할려면... 개인이 컴파일한 파일을 찾아서 사용해야 함~ -_-;


결국 php 5.2.x 버전으로 설치해서 큐브리드에서 공식적으로 지원하는 파일 php_cubrid.dll 파일을 사용하는게

정신건강에 매우 좋다는 이야기 입니다~ 이상입니다~