Skip to main content
XE 잡담
2012.12.26 10:56

php 5.3 대응하기

조회 수 6510 추천 수 0 댓글 1
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

xe 1.6 버전부터 php 5.3 이상부터 지원한다고 하길래...


이참에 보조서버 php 버전을 업그레이드 하였는데...


xe를 포함하여 다른 프로그램들까지... 모조리 error를 뿌리며... 날 당혹케 했다.


우선 php.ini 기본 조건은 그대로 둔체 php 파일 상단에 아래와 같이 추가 하였다.


@error_reporting(E_ALL ^ E_NOTICE ^ E_DEPRECATED);


그런데 모든 파일에 위와 같은 문구를 추가할수 없으므로... php.ini 파일 수정이 불가피 할 것 같다.



아무튼 권고사항 같은 표시는 기억해 두었다고... 나의 코딩 습관을 고쳐 나가는 것이 좋을것 같다.


그리고 변수관련 사소한 부분들도 앞으로 잘 지키는 것이 좋겟다.


$_POST[name] : X

$_POST['name'] : O


홋따옴표를 반드시 넣어서 코딩하는 습관을 들이자~


$content .= '여기는 내용입니다.'; : X

$content = '여기는 내용입니다.'; : O


변수를 처음 선언할때 .= 이렇게 쓰면 안된다. 이렇게 하려면 그 앞에 $content = ''; 미리 선언해 줘야 한다. 귀찮구먼유~ ㅎㅎ


아무튼 보안, 속도, 안정성 면에서 좋다고 하니 업그레이드는 해야 하는게 마땅한것 같고...

다만 대처할만한 시간이 필요한것 같다~

  • profile
    geusgod 2013.01.21 17:48

    1.5.x 버전에서 /config/config.inc.php 파일에 이미 관련 문구가 추가 되어 있다.
    php.ini 파일을 안건드리는 것이 좋겠다.


    하지만, 테스트 어떻게 진행하느냐에 따라 문제는 발생한다.

    1.4 버전 소스를 php 버전이 올라간 서버에 옮길때에는 config.inc.php 파일 상단을 아래와 같이 수동으로 바꿔줘야 한다.

    수정전 : @error_reporting(E_ALL ^ E_NOTICE); 
    수정후 : 
    @error_reporting(E_ALL ^ E_NOTICE ^ E_DEPRECATED);


List of Articles
번호 카테고리 제목 글쓴이 날짜 조회 수
3 XE DB XML 쿼리 sort 정렬 두개 처리하는 방법 geusgod 2012.05.22 6359
2 XE DB XE MSSQL 2005에 설치하기 2 종스 2009.11.19 25675
1 XE DB XE xml Query 테이블간 조인하기 종스 2009.11.05 27001
Board Pagination Prev 1 Next
/ 1